New Computer 12.3.1 NO iFamily?

If you are having difficulty using iFamily for Leopard.
eg: "How do I change someone's sex after they are married?
Post Reply
Kathy LPV
Posts: 17
Joined: Sat Aug 25, 2012 11:36 pm

New Computer 12.3.1 NO iFamily?

Post by Kathy LPV » Tue May 03, 2022 6:02 am

Hi again,
I believe I posted in January about this problem in March. We got a new computer in January, a gift from our kids. So "Monterey" version 12.0.1. {Monterey was created in Oct 2021]. SO naturally, I came here to download the latest version. I did - & have multiple times from January 2022 [v 2.895 ? - which has a large white circle & a line through it] to May 2022 - But the iFamily had the version [DMG] for 12.2.1 when mine was 12.2.1 - But the program never opened on this computer. Actually, I did get into it once, but when I tried again a few minutes later, it did not open at all! & it hasn't opened since. My only saving grace is I kept the older computer & it works on it. [But it's aa pain-in-a-neck to go back n forth to add new data.]

In Applications I have 2 leaves - 1 is "iFamily for Leopard.app" [the leaf has a large white circle & a line going through it].
The other created Oct 2014, modified Nov 2021 [& today 3 May] it is v 2.12.0 - I also have 3 iFamily dmg: v2.9.4 2016. & dmg v 2.9.6 & v 2.12.0 dmg.
But when I click on the v 2.12.0 leaf "modified Nov 2021 [& today 3 May] - OR - the leaf on my doc, it opens a box: "Open" or "Show Application" or "Cancel" and this:
"You are opening the application “iFamily for Mac.app” for the first time. Are you sure you want to open this application?"
& "The application is in a folder named “iFamily for Mac.” To see the application in the Finder without opening it, click Show Application."
- IF I click on "Open' Nothing happens. If I click on Show the Application the iFamily Box comes on with the leaf - with the arrow to move to Applications - which I've done dozens of times.
Yet clicking on either the leaf v 2.12.0 in Applications, or the one on my doc - does not open my iFamily Program ?!?

It's frustrating, I've tried everything I know to install & pull it up, but I still can't get into it. Is there a newer version than 12.2.1 out yet? I haven't gotten any answer about this - Am I doing something wrong here? Should I delete ALL on this computer & re do the download? Or just delete the oldest ones/ [ -But will deleting it them affect my other computer - since Monterey has deleted my my games on the other computer - though I haven't updated anything on it.]
Please Help . . . I don't want to loose all my data! And I don't want to use any other program than iFamily - it's perfect for me.

NigelRichman
Posts: 288
Joined: Sun Oct 19, 2008 7:12 pm
Location: Cornwall, England

Re: New Computer 12.3.1 NO iFamily?

Post by NigelRichman » Tue May 03, 2022 11:44 am

Hi Kathy

The application you need to use is the v2.12.0 Leaf in the applications folder.

It sounds to me as if that application runs but has not loaded your iFamily database file.

As you have moved to a new computer it is possible that the database file is not in the correct location.

Where is your iFamilyData folder and the ‘your family tree’.ftksql file?

When installed iFamily puts the iFamilyData folder in the correct location for the new operating system- it changed a while back

If you can find your ftksql file and move it to the iFamilyData folder in Documents you should be able to get going once more.

Hope this helps

Nigel

Post Reply